stiletto 2 car dock problems

Discussion in 'Sirius Portables' started by fatkidwithoutcak, Oct 31, 2008.

  1. fatkidwithoutcak

    fatkidwithoutcak New Member

    So I just got a Stiletto 2 two days ago and I also bought a car dock. So I hooked everything up and now it's doing some strange things. I've read up on some of the problems with the Stiletto 100 and I've tried some of the advice but I can't get it to work properly.

    I almost always get a "Antenna not Detected" or "acquiring signal" message. Once yesterday for about 15 minutes I had a full signal but that hasn't happened again.

    I've tried to take out the battery and then put it on the dock and that sort of works but I get an absolutely horrid signal, if one at all.

    Also yesterday I was trying to get the fm transmitter to work but it would even pull up the channel selector when I held the button down. (I'm now using a direct to tape converter thing.)

    The remote does absolutely nothing.

    But it charges the battery and it will play mp3s
    And everything seems to be hooked up right.

    Is it a bad dock or antenna? What should I try doing? And if it is the dock should I just return it to Best Buy or deal with Sirius Costumer Service?
    Any and all help will be appreciated.
     
  2. MM

    MM Administrator

    Is the antenna on the roof of your vehicle?

    Did the antenna click as you pushed it into the dock?

    If you go into antenna aiming, what does iy say?

    Do you have another antenna to try?

    Are you using the new antenna that came with the SL2 dock?

    Is the battery in the remote?


    Sorry if these questions seem trivial, but I want to cover all the bases.

    BTW, welcome to DRC!
     
  3. fatkidwithoutcak

    fatkidwithoutcak New Member

    The antenna is on the roof where the guild said it should be.

    I can't even get the antenna cable out of the dock, so I'm pretty sure it's in all the way.

    Antenna aiming just gives me the usual message with both bars totally empty.

    I don't have another antenna since I just got my radio.

    The antenna I am using is the one that came with the car dock.

    And yes the battery is inside the remote.

    Thanks
     
  4. MM

    MM Administrator

    I suggest that you head back to BB and get a new dock (bring all your SL2 stuff as well, just in case). Don't deal with Sirius.

    You'll be able to do an even exchange.

    Then go to the parking lot and try it again. Plug in all the cables and put the antenna out your window on the roof and see if you get a signal. If you do, you're in business. If not, take your SL2 back for an exchange as well. Then try again.

    Let us know how it goes.
     
  5. Did you install wire through door frame? If you are closing door on wire you may have broken the wire.
     
  6. mynameisjamie

    mynameisjamie Member

    Does the Stiletto get a signal when you are using the antenna headphones?
     

Share This Page