S50 No signal - should I give up the ship?

Discussion in 'Sirius Portables' started by stankbee, Nov 20, 2008.

  1. stankbee

    stankbee New Member

    Hello. I've done searches on this forum, the SBS forum, and Google but can't find any answers. I have the dreaded No Signal problem. No reception even though my antenna aiming screen shows I am getting good signal. By pulling the battery, I can usually get reception for about 10 minutes before the radio displays No Signal and goes silent. My saved music and playlists work fine though.

    I know it's not the antenna because I've tried 4 different ones. I am also able to use an older, cheaper Sirius radio with these antennae with no problems. I have updated to the latest firmware, updated the channels, pulled the battery, bought a new car dock, etc. Everything but the 3-finger salute. These failed atempts have me convinced that the problem is with the player itself, not the antenna, dock, connections, or any of the usual suggested culprits.

    Has anyone used the 3-finger successfully to fix this issue? I have too many songs saved to go into this lightly, but I'm just about at the point of trying this. The only thing holding me back is at least I can use it as an MP3 player with a great FM modulator. If the 3-finger does nothing, it will truly be a worthless paperweight. Thanks in advance!!

    Chris
     
  2. me_rubin

    me_rubin Member

    Chris,

    If I had to guess, I'd say it is heat related to the antenna connection. You say it will work for 10 minutes then stop receiving. Maybe it might be the connector at the bottom of the radio.

    I just wonder if it is the Dock or the radio. Do you only have one dock? Home or Car? In that way you could see if that makes a difference.

    If it were me I would not invest anymore in the radio.
     
  3. stankbee

    stankbee New Member

    Me Rubin, thanks for the quick reply. I originally thought the defect was in the car dock too, since that is what the antenna is connected to. However, I was able to purchase a replacement car dock off ebay, and that did not solve the problem. You're antenna heat theory is interesting though. I have no idea what might cause the problem to occur after working for a few minutes. I had thought maybe static electricity was building up in one of the components, but that was just a wild-arse guess. Have you heard of anyone else having problems with heat building up?
     
  4. me_rubin

    me_rubin Member

    You could have two bad docks. I know there were plenty of them. Ebay is a way to get rid of a bad dock. Possibly someone near you has a working unit and can let you try yours in the dock.

    If it is the unit itself then the only other thing is to mail it in and get it exchanged.

    I had to do that twice to get mine finally working.

    Here is the link:
    Welcome to FTH Group Inc.

    The've extended the period until Nov. 30th.

    It will cost you about 10 bucks in ups fee's to ship it. Follow the directions and remember not to ship your battery or back of case as you won't get another one when its returned.

    Most of the time, 100% in my case they send you a refurbished unit and do not do any upgrades.
     
  5. almaniac27

    almaniac27 Member

    The website only says that they update the radio. They do actual exchanges too? I might have to do this too.

    A customer service rep once told me that there are a few different models of the S50. Is this true? She said that later ones might be compatible with the Best of XM package. I wonder if I send my S50 in they might give me a more recent model.
     
  6. me_rubin

    me_rubin Member


    Yep, if they cannot update it or it does not work after the update, they exchange it.
    Just start a 3 finger on it before you ship it out so it appears not to have any operating system on it.

    My last one I exchanged had sent in had much the same symptoms as it would not receive. It could play mp3s but no sat reception.

    You better do it quickly as you don't have much time left, ( they have extended it already )
     
  7. almaniac27

    almaniac27 Member

    What's the 3 finger thing? I'm guessing some sort of reset but I don't know how to do it.
     
  8. me_rubin

    me_rubin Member

  9. almaniac27

    almaniac27 Member

    I decided to go ahead and try the whole process first and see if that helps. Unfortunately, I think it's messed up. The S50 is stuck displaying "USB2.0 MSD" and the My Sirius Studio won't recognize that I connected the S50 to the computer.
     
  10. nafddur

    nafddur Member

    I say anyone agonizing over getting their S50 working is crazy. These things have been obsolete for years!

    I say just trade it in on an S2. They're still not perfect (what is, these days?), but they do way more than the S50's and - more importantly - they work way better.
     
  11. JoeTan

    JoeTan Well-Known Member

    NO way. S50 4 life!
     
  12. IronJabroni

    IronJabroni Well-Known Member

    another S50 here doing just fine
     
  13. me_rubin

    me_rubin Member

    Go to the sirius support page and make sure you download the MSS version for the s50 along with the s50 driver. Otherwise your computer does not connect to s50.

    You can also download the s50.mi4 file and then copy it to the root directory of the s50 and reboot. This brings over the latest software.

    Over on the SBS you will see many posts by me and others of how to handle these isues. But like I said earlier, Mail it in for the cost of postage. Let them upgrade the bios firware and if they cannot they give you a new refurbished unit with the latest.

    Now that your unit is stuck in the midde of the 3 finger is the perfect time to send it in.
     
  14. stankbee

    stankbee New Member

    Thanks for the info! I am going to send it in, even though it sounds like I'll lose all my saved songs. I was able to update my s50; it just didnt solve my problem (or possibly created it). Any particular reason to perform the 3 finger on it first? I'm afraid they will just reinstall the new firmware and send me the same unit which will stop working after ten minutes.
     
  15. stankbee

    stankbee New Member

    I've been tempted to do this. However, there are 2 reasons I prefer the s50 over the s2: 1) The s50 allows me to record a block of music and then FF thru the block to pick out songs to record. My understanding of the Stiletto's is you can only grab songs that you are listening to live. This is a big deal to me. 2) The s50 has a really strong FM transmitter. I believe this was actually a mistake, one that's been "corrected" in the Stiletto.

    I really don't know much about the S2 though. Can anyone confirm these 2 facts. I would actually love to be wrong. Then I could just do the damn thing (switch to the S2)!
     
  16. me_rubin

    me_rubin Member

    You can schedule recording of music so you get a block this way, Otherwise you are correct you can only hit the record button while the song is playing to get it recorded.

    The fm modulator for the Sl100 and sl2 is weak. the S50 was much stronger, but later it was made weaker.
     
  17. Musicologist

    Musicologist Member

    Due to FCC regulations/mandates that were outside of Siri's control.
     
  18. DLSieving

    DLSieving New Member

    "Poor Signal Quality": The Most Obnoxious Quip in my Life Today

    I sure hope Sirius receiver models after the S50 have dumped this obnoxious, non-configurable annunciation. Back in the day, the sound of static on a car radio was widely understood. Why in the modern age do we need to have it spelled out for us every time we pull into the garage? And why can't we turn off this useless annunciation?

    :headbang:

    Never mind, just venting, and calling on all firmware programmers to think twice before embedding indelible audio messages without giving due consideration to the long-term user experience.
     
  19. nafddur

    nafddur Member

    I've never heard any annoying audio messages on any of my S50's, SL100's or current S2. Then I remembered that turning off the `speak channels' and `system sounds' option is always the very first thing I do after activating a new receiver.
     

Share This Page