Using msconfig to prevent unnecessary programs from starting

Oren

Well-Known Member
Oct 13, 2008
1,863
34
48
55
NE NJ
How frustrating! I've used msconfig in an attempt to prevent some unnecessary programs from starting upon bootup by unchecking the programs under the Services and Startup tabs.

This puts the PC in Selective Startup Mode (as shown under msconfig's General tab). But this causes the following nag message to appear every time XP boots:

"You have used the System Configuration Utility to make changes to the way Windows Starts.

The System Configuration Utility is currently in Diagnostic or Selective Startup mode, causing this message to be displayed and the utility to run every time Windows Starts.

Choose the Normal Startup mode on the General tab to start Windows normally and undo the changes you made using the System Configuration Utility."


If I choose Normal Startup mode, the unchecked (unnecessary) programs are re-checked again. If I select the do not show this message again box on the nag message, it also re-checks the programs that I don't want to load upon bootup and puts the PC back into Normal Startup mode. So it appears that using msconfig to prevent these programs from loading is a futile process (unless you want to deal with the nag message every time XP boots).

Am I doing something wrong?? Is there a better way to prevent these programs from loading when XP boots? My problem is when all these programs load, XP bootup and shutdown times take forever. When it's in Selective Startup mode, bootup and shutdown times are very significantly reduced (but the annoying message appears every time I boot up).


:bigahh:
 

xan_user

Banned
Dec 16, 2008
3,234
74
48
Nor-Cal
that's not working right. clicking the do not show box on the nag should not recheck the unchecked programs, and should stop the nag on next boot. i guess you could try disabling the programs one at a time then reboot once to change nag and a second time to see if it stuck.
 

Oren

Well-Known Member
Oct 13, 2008
1,863
34
48
55
NE NJ
that's not working right. clicking the do not show box on the nag should not recheck the unchecked programs, and should stop the nag on next boot. i guess you could try disabling the programs one at a time then reboot once to change nag and a second time to see if it stuck.

It does recheck the programs after checking the do not show box on the nag window. And it seems that it's working that way by design... Checking do not show again puts XP back into Normal Startup mode.
 

Oren

Well-Known Member
Oct 13, 2008
1,863
34
48
55
NE NJ
that's not working right. clicking the do not show box on the nag should not recheck the unchecked programs, and should stop the nag on next boot. i guess you could try disabling the programs one at a time then reboot once to change nag and a second time to see if it stuck.

You're correct. It's clearly not working right.

I think I'll download another utility to see if I can prevent the programs from loading that way. There's clearly a problem with msconfig on my system.
 

xan_user

Banned
Dec 16, 2008
3,234
74
48
Nor-Cal
it sounds like something a Trojan would do.

run ccleaner in safe mode and malwarebytes in regular mode .
 
Last edited:

Oren

Well-Known Member
Oct 13, 2008
1,863
34
48
55
NE NJ
I know what happened now. This whole malfunction was caused by a registry cleaning program.

I've run it a few times over the last year, and when it came up with 100+ "errors", I went through the "major" ones, and didn't look into the "minor" ones and selected "Repair All". That f-ed something up with regard to msconfig.

Luckily I set the program to create XP restore points before it "repairs".

I'm OK now. Totally fixed. FINALLY!!

;)
 

ProperModulation

Green Type of Tube
Oct 11, 2008
2,612
90
48
California
Just back up and reformat. I reformat at least once/year.

If you reformat so often, I suggest that you take a look at Norton Ghost. Whenever I build or buy a new machine I configure Windows the way I like it then I use Ghost to make an image (which I back up of course...). Then I load my base software (office, my favorite utilities, etc...) and make another image. That way if I ever want to get back to a clean configuration, I simply apply the image (clean, or with apps) and I'm done. It's a lot easier and faster than re-loading from scratch. Plus it's saved me a ton of headaches the one or two times I have had a primary hard drive failure or just wanted to upgrade my primary drive. Ghost can be a bit pricey, and I am NOT a fan of Norton products, but it is typically one of the first applications I load on a new system.
 

v1ru5

Well-Known Member
Oct 24, 2008
1,690
67
48
Harrisburg PA.
Go into the options of the program you do not want to start and see if theres an option to "Do not start with Windows".
 

memebag

Top Brass, ADVP
Oct 11, 2008
17,407
5,814
168
Lake Huntzing
For services, you can also go to the Services page from the Control Panel and change the "Startup Type" from "Automatic" to "Manual" or "Disabled".
 

Oren

Well-Known Member
Oct 13, 2008
1,863
34
48
55
NE NJ
So you know, I'm a geek. :p

I wish it were that easy. I'm totally OK now though. How ridiculous. :rolleyes: