TOY-SC1 not visible to Toyota nav system when smartkey fob is not present

Discussion in 'SiriusXM Install Bay' started by larryb58, Jan 3, 2009.

  1. larryb58

    larryb58 New Member

    I just installed a TOY-SC1, SCV-DOC1 and Sportster 5 in my 2007 Camry Hybrid, which has the Toyota nav system, factory security system and smart key system.

    On post-install testing everything worked fine. But when I got back in the car this morning the head unit failed to find the SC1/Sportster. When the head unit powered up the channel preset list appeared momentarily but with no channel info text. Then the head unit turned itself off.

    When I turned the head unit back on, pressing the SAT/AM button wouldn't call up the SC1/Sportster--I could only get AM stations. I turned off the car's power, then turned it back on and could then press the SAT/AM button to use the Sirius radio again. There's a loud pop every time the Sirius radio powers up, but everything works again--presets, tuning, audio output, etc.

    After some troubleshooting I noticed that the failure is related to the smartkey system. As long as the key fob is in or near the car I can turn the car on and off and every time the satellite radio functions normally--though the pop is always there on startup. If I take the key fob away from the car, then come back and turn the car on, I get the failure noted above.

    Anyone seen this before? Any ideas for resolving the issue? Seems quite strange that the smartkey would have an effect here. And is the pop on power-up normal, or is there a way to fix that, too?

  2. Mopar86

    Mopar86 Member

    I assume this is Push Button smart key technology. Try This:
    Press the start button once(without the brake pedal) to activate ACC mode
    Next Press the brake pedal and then press the Start button.

    For some reason several people I talk to have had problems with push button start and this has taken care of it every time. It is an extra step you have to take, but no one seemed to mind it much.

    The Power-up POP noise I have seen resolved in the past with a noise filter. A few large amplifier car audio systems I have worked on suffered from this and a noise filter was the solution. It would have to be wired into the power system of the vehicle.

    The key fob thing I cant understand, So when you get in the car and start it is works? But when you leave with the fob and come back it does not work? When you come back with the fob try and just hit the start button(without brake pedal) then start button with brake pedal to start the car.

    Post back any results from this or if I am unclear on something, Thanks
    Last edited: Jan 3, 2009
  3. Mopar86

    Mopar86 Member

    The only thing I can figure out why push button is different is that, when a car is push button started it goes straight to ignition or start, while in normal cars they cycle through ACC then ignition/start, my conclusion(and this could be way off,but its the only thing i can think of that makes sense) is that the SIRIUS Tuner and/or Interface needs to be cycled through ACC before constant power/ignition.
  4. larryb58

    larryb58 New Member

    After a weekend of reading the Toyota manual and further troubleshooting, it appears that the presence/abscence of the key fob is a red herring--the system has sometimes initialized fine even when I take the fob away from the car, and other times when the fob remains present initialization fails.

    From reading the head unit diagnostic codes the issue is that the TOY-SC1 isn't always able to join the networking bus. There are trouble codes stored for the AVN-LAN relating to the SC1 not responding to power on commands and not changing modes. It does seem that turning on the accessory power (pushing Start button without pressing the brake pedal) lets the SC1 join the bus successfully, and going directly to Run mode (pressing the brake and then hitting Start) results in frequent failures and trouble codes. I'm guessing that with fewer networked components coming online in Accessory mode, there's less buss contention and the SC1 can properly power up and connect to the bus.

    That said, I wonder if this could be due to a bad SC1--if there's a problem with this particular unit that causes it to either power up slowly or not properly execute the bus join. Or if there's a firmware bug in the head unit or the SC1 that doesn't properly do the join. This is a very early production Hybrid so it's possible that a bug was found and later fixed. In any case, it seems strange that the bus join protocol wouldn't be designed to properly handle the contention.

    I'll try calling Directed Electronics tech support on Monday to see if this is an issue they're aware of.

    I believe the pop is a digital framing pop, not a tuner/amp pop. When the SC1 is initializing I see an "Acquiring tuner" or "No tuner" message on the head unit. When the SC1 connects the message changes to Acquiring. That's when I hear the pop. There are no similar pops when the audio source is any other audio source.
  5. SubSonic

    SubSonic New Member

    Just playing devil's advocate here, nothing harsh intended, but have you thought about *not* over-thinking this deal?

    If this weren't a "hybrid" with "push button start" and so on and so forth, I'd otherwise simply ask if you have rechecked all your connections. The cable between the TOYSC1 and SVCDOC1 only makes a tenous connection with the TOYSC1 at best - the dock end appears to lock in easily, the TOYSC1 end not so much. Mine unplugged twice on its own during my install (TOYSC1/SVCDOC1/Sportster 4 in a 2008 4Runner wtih JBL Nav/4 disc changer). Not "all the way" unplugged, but enoug that intermittent problems like this surely could have resulted from it.

    The fact that it works AT ALL at times tells me that it is likely not really related to the newness of the Nav System or the car. If it were some sort of hardware or firmware problem like you're thinking here, I don't think it would have ever worked properly. That "pop" you're hearing could also be the result of a non-solid connection somewhere in your TOYSC1/Sportster cradle.

    Just an idea anyway.

Share This Page