Stilletto 2 Battery

siriusnj

Member
Oct 29, 2008
45
1
8
I was wondering if anyone has seen this issue before - I've had my SL2 for 2 years and have never had any problems with the battery or hardware. Lately though, while in the dock, the battery does not charge, yet it is clearly connected to the dock because I get satellite reception. Sometimes it is charging as can be seen by the lightning bolt in the bottom left, but it randomly stops, and sometimes goes in and out, while other times just doesnt' come back. If I push it a bit I can get it back. I am just wondering if it's a bttery issue or if it is a SL2 issue - I would get another battery but don't want to waste the money if it's a bigger issue than that. Thanks for any thoughts.
 

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
21,611
9,270
168
Toronto, ON
I was wondering if anyone has seen this issue before - I've had my SL2 for 2 years and have never had any problems with the battery or hardware. Lately though, while in the dock, the battery does not charge, yet it is clearly connected to the dock because I get satellite reception. Sometimes it is charging as can be seen by the lightning bolt in the bottom left, but it randomly stops, and sometimes goes in and out, while other times just doesnt' come back. If I push it a bit I can get it back. I am just wondering if it's a bttery issue or if it is a SL2 issue - I would get another battery but don't want to waste the money if it's a bigger issue than that. Thanks for any thoughts.


It could be either the battery, the SL2 or the dock. Have you tried charging it without the dock and see if the situaltion changes? This may help you isolate the problem.
 

Vols44

Well-Known Member
Oct 18, 2008
1,225
136
63
Recently had the same problem with my SL100, battery and home docking system. I like to record at night and listen by day. Didn't get channel 100 the last two nights because either slim battery I used didn't stay charged. I originally thought it was overheating and shutting down so I place the dock in front of a fan over night and the same thing happened.

This evening I'm trying for a Howard replay and using the "fat" battery to isolate the problem.
 

Vargas

Molon Labe!
Oct 16, 2008
3,426
153
63
Western, PA
This is a problem with the SL2's connections on the bottom of the player, not the dock and not the battery of the SL2.

I know because I have the same problem but my problem is worse. I think, over a long period of time and when you are a heavy user and constantly switch docks, your connections become loose on the player.

I now can ONLY charge my SL2 in my boombox but that is after I use a peice of tape to pull the player backwards so the connection is made.

Sorry to tell you but your problem will only get worse with time.
 

siriusnj

Member
Oct 29, 2008
45
1
8
This is a problem with the SL2's connections on the bottom of the player, not the dock and not the battery of the SL2.

I know because I have the same problem but my problem is worse. I think, over a long period of time and when you are a heavy user and constantly switch docks, your connections become loose on the player.

I now can ONLY charge my SL2 in my boombox but that is after I use a peice of tape to pull the player backwards so the connection is made.

Sorry to tell you but your problem will only get worse with time.

Bummer to hear, I just wasn't sure because my SL2 was connecting to the dock, but I guess the slot where it charges is not. I did notice that if i push the player back a bit, it does start charging. I guess I will need to form my own contraption until we finally get a new player. Thanks.