Stiletto help needed.

jmarren

New Member
Nov 25, 2009
23
0
1
I have a Stiletto 10. When Sirius merged their stations with XM I lost a lot of the graphics on the screen. The XM stations such as deep tracks do not have any graphics. The background is blue and the lettering is standard (no logo). I thought that over time Sirius would send an update to my radio like when they added Lithium (Lithium had no graphics for about 6 months and was then updated). I recently updated my Stiletto but it didn't fix it. Sirius has told me to do a system restore which will reset my radio to the original factory settings. I am hesitant to do this since I will loose all of the saved info such as my artist seeks. Any help would be greatly appreciated.
 

Vargas

Molon Labe!
Oct 16, 2008
3,426
151
63
Western, PA
I have a Stiletto 10. When Sirius merged their stations with XM I lost a lot of the graphics on the screen. The XM stations such as deep tracks do not have any graphics. The background is blue and the lettering is standard (no logo). I thought that over time Sirius would send an update to my radio like when they added Lithium (Lithium had no graphics for about 6 months and was then updated). I recently updated my Stiletto but it didn't fix it. Sirius has told me to do a system restore which will reset my radio to the original factory settings. I am hesitant to do this since I will loose all of the saved info such as my artist seeks. Any help would be greatly appreciated.

I woundn't do the system restore.

Have you connected the SL10 to your PC and did the software update? I don't know what your current firmwear version is but I think the last updated fixed SOME of the logo issues.

However, I wouldn't do the restore at this point. You can, it isn't a disaster but you WILL lose all presets, loved songs, etc.

Try the firmwear update first (connect to PC, open MSS and then do the "look for software update."
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,298
6,824
168
Toronto, ON
SL10 and SL100 have no logos. Sirius hasn't bothered updating then. A system restore will not solve your problem.