Stiletto 2 Wi-Fi problem

Stern Lover

New Member
Jun 3, 2009
4
0
1
I am getting a "Can't play station - try again later" error when I connect to any station thru Wi-Fi. I just spent an hour on the phone with Sirius tech support and they couldn't solve it. It's possibly related to my changing my username to listen to Sirius online but no one knows if this is stored on the Stiletto and, if it is, how to update it.

Any thoughts?
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,357
6,891
168
Toronto, ON
I am getting a "Can't play station - try again later" error when I connect to any station thru Wi-Fi. I just spent an hour on the phone with Sirius tech support and they couldn't solve it. It's possibly related to my changing my username to listen to Sirius online but no one knows if this is stored on the Stiletto and, if it is, how to update it.

Any thoughts?

The Stilletto does not use the user name. However, it does need to be attached to the account. My guess is that your SL2 is not attached to your new account correctly. One thing you can try is to delete your WiFi setting from your SL2 and let it re-discover it and see if that helps. Otherwise, go online and see if you can see your SL2 attached to your internet stream.
 
Oct 10, 2008
644
11
18
Chicago
"Re-discover" the WIFI signal is a great idea. I too think it could be a new account setting, but changing user name and password wouldn't affect this. Also, try on a different WIFI network. If you are at home see if you can't talk to a neighbor and jump on theirs just to test it. If it's at work then try yours at home.
 

columbo1969

New Member
Jul 26, 2009
1
0
1
Did you ever find a solution to this problem, because I'm having the same issue. Tech support stinks! Already "rediscovered" my wi-fi and still not working. I know I'm connected but still I get no staions.
 

Stern Lover

New Member
Jun 3, 2009
4
0
1
Still not working

Did you ever find a solution to this problem, because I'm having the same issue. Tech support stinks! Already "rediscovered" my wi-fi and still not working. I know I'm connected but still I get no staions.

No, I haven't fixed it yet. I'm back on hold with Tech Support now. I've reset, re-logged-in, re-everything possible and nothing's fixed it.

The one thing I haven't done is try it on another network. We have free WiFi in our lobby, so I'm going to wander down there as soon as I'm done on the phone.

Very frustrating!
 

Stern Lover

New Member
Jun 3, 2009
4
0
1
The Stilletto does not use the user name. However, it does need to be attached to the account. My guess is that your SL2 is not attached to your new account correctly. One thing you can try is to delete your WiFi setting from your SL2 and let it re-discover it and see if that helps. Otherwise, go online and see if you can see your SL2 attached to your internet stream.

Thanks for the tips. Can you provide specifics on where to go online and see if my SL2 is attached to my internet stream?

FYI, just did a full device recovery and still have problem...
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,357
6,891
168
Toronto, ON
Thanks for the tips. Can you provide specifics on where to go online and see if my SL2 is attached to my internet stream?

FYI, just did a full device recovery and still have problem...

Goto your account (from SIRIUS Satellite Radio - Everything worth listening to is now on SIRIUS) and once you login, you will see your contact info, billing info. Then you will see a "Services" section. You will see your satrads (all your ESNs) and their billing plan. Then you will see the Internet radio section. What I see on mine is my UserName, my SL2's ESN, the package (mine says "Sirius Internet Radio"), and login type of Master.

My guess is you will not see your SL2's ESN attached to your login.