Stiletto 2 shutting down not going to sleep mode

TAZLV

Member
Oct 12, 2008
31
1
8
Las Vegas, NV
Has anyone had this problem my SL2 is not going to sleep mode just shutting down all the time. I tried reset and that hasnt solved the problem.
 

acap

Member
Oct 16, 2008
34
0
6
I'm having the exact opposite. Mine will go to sleep, but wont shut down.

How long are you holding the button down?
 

MM

Administrator
Oct 9, 2008
4,312
105
63
New England
This has happened to mine, but off and on. When I wanted it to do either, it would do the opposite. Sometimes when I think I put it to sleep, it shuts down.

It might be a bug issue. DAB?
 

DAB

Mod Emeritus
Oct 9, 2008
9,434
149
63
Louisiana
Strange I've never experienced that. I know when I first got SL2 I found it rather hard to make it shut down using the button. But once I learned it. I just do a very quick push of the button and it will go into standby mode. If I want it to shut down, then I use my nail and hold it down for 5 sec. This works like a charm. So standby is just a quick instant push of the button. I guess its more of switch than a button since you actually slide it down.
 

TAZLV

Member
Oct 12, 2008
31
1
8
Las Vegas, NV
It is only happening when I shut off the SL2 manually.....When it is docked I use the remote and it goes to sleep mode. Seems like it is the switch that is defective. Anyone think the device recovery program would work? Otherwise I will just use the dock to turn it on and off.
 

me_rubin

Member
Oct 11, 2008
509
24
18
64
Herndon, VA
Normally a battery pull will solve some of these problems. But I know I have seen strange things. On one of my home docs ( converted from SL100) if my readio is off, It would randomily turn itself on. I actually figured out that power connector was loose and the rattling or bumping of the table would disconnect and connect it enough to power itself on.
 

Allanon

Member
Oct 17, 2008
313
16
18
It is only happening when I shut off the SL2 manually.....When it is docked I use the remote and it goes to sleep mode. Seems like it is the switch that is defective. Anyone think the device recovery program would work? Otherwise I will just use the dock to turn it on and off.
A similar problem happened with my previous SL2 unit within 6 months of purchase. The switch became defective. When I held the button for 10 seconds, the SL2 would go directly to sleep (within 1 second), then come back on a few seconds later, and finally shut down, barely showing the 'shutting down...' message. Within a few weeks, the SL2 stopped waking up altogether and I had to get it replaced under the warranty.

I just hope, for you, that the same isn't happening to your unit.
 

TAZLV

Member
Oct 12, 2008
31
1
8
Las Vegas, NV
All is well now......seems after 2 days of shutting down and rebooting umpteen times it has fixed itself.....it now goes to sleep mode when I manually switch it off.