Stiletto 100 -- No Audio

Discussion in 'Sirius Portables' started by 97formula, Jul 3, 2016.

  1. 97formula

    97formula Member

    Audio suddenly stopped working on my SL100. Menus are navigable (no sound there either), already tried powering off, leaving the battery out overnight, tried several docks (including my boombox), nothing.

    Anyone else experience this? If so, can something be done or is the unit pretty much done?

    Thought of getting a SL2 but the guides are different (I remember seeing a few write-ups on how to make SL100 docks fit SL2). But what about my boombox (can the metal guides be removed)?
  2. semipenguin

    semipenguin Cheeseburger Connoisseur

    Does the audio work with headphones?

    Or only in the boombox?
  3. 97formula

    97formula Member

    No sound from headphone jack either. When in library, I hear a slight "click" when I change tracks (never heard that before)
  4. HecticArt

    HecticArt Administrator

    Have you tried to reset and erase? Return to factory settings?

    If those don't work, there's a thread around about a "Three Finger Salute" that will take you to the hidden boot menu thing. You always run the risk of bricking your radio if you go to that menu, but if the other things don't work, with a radio that old, you might not have anything to lose. Once you get to that menu, there is a clear cache option, and something else (that slips my mind) that are worth trying.

    Good luck, and keep us posted!
  5. 97formula

    97formula Member

    Nope....reset and erase did not help.

    I gave up and picked up a Stiletto 2 from someone local. Trying to get the latest ZAP update (My Sirius Studio says no updates, but it's only on 2.0.2 (latest is 2.0.5 I believe).
  6. semipenguin

    semipenguin Cheeseburger Connoisseur

    Tss Radio has a repair service

    SiriusXM Radio Repairs to Fix: Screens, Audio Jacks, Buttons | TSS-Radio

    Don't know how much it will cost. Contact them on Tuesday & they should be able to help you
  7. 97formula

    97formula Member

    I figured out how to get into recovery mode (pressing options and display pretty much "bricks" the unit, making it necessary to recover).

    Problem is, that the latest version downloads off a website that I think is offline since the process times out right at that moment.

    I did manage to recover my SL100 using VirtualBox (XP 32-bit OS installed on a Win10 64-bit laptop). I needed to use the original CD that came with my SL100.

    After all that, it did not resolve my audio issue so the unit is pretty much done.

    My SL2 unit has outdated ZAP firmware. Is there a way to trick the MSS to pick up an offline copy (if so where can I find an offline copy of ZAP and OS

Share This Page