Starmate 5 concerns...

Max

New Member
Aug 2, 2009
4
0
1
Long time Sirius subscriber (2004') and newbie forum member here. :p

My old ST-2 died recently displaying "Call to Subscribe", so off to Sirius Tech I went. Unit was deemed needing replacement.

Got the newest ST-5 at a killer deal ($39 w/vehicle kit) two weeks ago but the new unit went strange on me a week later spouting random "channel saved" messages and beeping on its own. Then the 0 and 1 channel preset selection buttons quit working along with the "UP" direction selection button function. :confused:

Sirius made good on a next day warranty replacement, BUT...have we got a potential lemon here with the new ST-5 model? :eek:

I'd be interested to hear from others (good or bad ) on the subject of the ST-5.
 

Aaron

Moderator
Oct 10, 2008
13,713
8,547
168
South Louisiana
Got the newest ST-5 at a killer deal ($39 w/vehicle kit) two weeks ago but the new unit went strange on me a week later spouting random "channel saved" messages and beeping on its own. Then the 0 and 1 channel preset selection buttons quit working along with the "UP" direction selection button function. :confused:
It sounds like you're experiencing the same things that sometimes happen to my radio. Read this thread about Starmate 4 & 5, and let us know if it helps.

http://www.digitalradiocentral.com/sirius-radios/5515-problems-starmate-4-presets.html

Welcome to DRC!
 

Max

New Member
Aug 2, 2009
4
0
1
Thanks Aaron. That just may be the issue with my first ST-5, even after just a week of use and also storage NOT in the vehicle. :(

I guess that the strip issue could also extend to the "UP" direction selection button problem I had as well, huh.

Diff question, same unit model. My old ST-2 case had air vent slots. Does the ST-5 run that much cooler as to not NEED those same ventilation slots? :rolleyes:
 

Aaron

Moderator
Oct 10, 2008
13,713
8,547
168
South Louisiana
I'd say the strip issue is the one causing the 0 and 1 buttons and the Up button issues. That is what happens to mine, along with presets automatically setting themselves.

I think in the case of my radio, it is heat related. It never happens in the house, and it only happens if I leave it in the upright position in the car in the heat. It hasn't happened since I started remembering to store the radio on its side in the glove compartment. (Which shouldn't be necessary, but it has worked for me!)

Regarding the air vent question... I'll let someone from TSSRadio answer that one. :)
 
Oct 10, 2008
644
11
18
Chicago
Long time Sirius subscriber (2004') and newbie forum member here. :p

My old ST-2 died recently displaying "Call to Subscribe", so off to Sirius Tech I went. Unit was deemed needing replacement.

Got the newest ST-5 at a killer deal ($39 w/vehicle kit) two weeks ago but the new unit went strange on me a week later spouting random "channel saved" messages and beeping on its own. Then the 0 and 1 channel preset selection buttons quit working along with the "UP" direction selection button function. :confused:

Sirius made good on a next day warranty replacement, BUT...have we got a potential lemon here with the new ST-5 model? :eek:

I'd be interested to hear from others (good or bad ) on the subject of the ST-5.

Thanks Aaron. That just may be the issue with my first ST-5, even after just a week of use and also storage NOT in the vehicle. :(

I guess that the strip issue could also extend to the "UP" direction selection button problem I had as well, huh.

Diff question, same unit model. My old ST-2 case had air vent slots. Does the ST-5 run that much cooler as to not NEED those same ventilation slots? :rolleyes:

The strip problem is common and one we have been trying to tell Sirius about. I would get it swapped ASAP. As for the vents, it isn't necessary. For starters the new radios don't run nearly as hot as the older ones. Hope the replacement starmate works out better for you.
 

Max

New Member
Aug 2, 2009
4
0
1
Thanks Matt.

If you hear of any recalls or beyond normal warranty (no cost) corrective repairs or exchanges from Sirius on these units, please let us all know. ;)

I guess I'll just keep my fingers crossed in the mean time.:(
 

mcf57

Member
Dec 5, 2008
174
1
18
I have a Starmate 5 that has been hooked up and working flawlessly in a vehicle since Jan' 09. It sits in the vehicle ALL the time & connected to the front windshield. No problems so far & I have enjoyed the unit.