Sporster replay screen goes blue?

PMantle

New Member
Dec 3, 2008
18
0
1
Sorry if already covered here, but lately my unit's screen has started going blue out of the blue. Sometimes I can fiddle with it and get it back to normal. Sometimes I can't. I can barely make out the words on it. Any fixes out there? Could it be the dock and not the player? Thanks for any help.
 
Oct 10, 2008
644
11
18
Chicago
PMantle,

I need to know what model you have exactly. Is it the SPR2? And am I understanding this right? Your screen goes blue completely and you can barely make anything out on it? I have heard of this happening before and alot of times it means the unit is going bad. It is a common thing with older Sportsters. It usually has nothing to do with any power or docking station issues.
 

PMantle

New Member
Dec 3, 2008
18
0
1
PMantle,

I need to know what model you have exactly. Is it the SPR2? And am I understanding this right? Your screen goes blue completely and you can barely make anything out on it? I have heard of this happening before and alot of times it means the unit is going bad. It is a common thing with older Sportsters. It usually has nothing to do with any power or docking station issues.
Not sure, as it's out in the car. How can I tell if it's the SPR2?

But yes, you understood me perfectly. The screen turns light blue, and if you look really hard, you can see the information. Otherwise, it operates perfectly. Looks like I'll have to start searching eBay for a replacement. Love the unit because of the 6 lines of display. that way, I can see 6 of my presets all at once.