SL2: Updating Library??

North_of_Calgary

New Member
Oct 15, 2008
13
0
1
Well, I've seen messages about updating channels many times before but this afternoon it gave me something like:

Updating Library - this may take several minutes to complete
And it did take 2 or 3 minutes and big surprise, after it was done all of my recordings (two Stern shows) were gone. That's the 3rd time in as many weeks that I've lost all recordings. My faith in it has gone down to zero - in fact if my timer does work and does record without erasing my other recordings it's like a pleasant surprise.

But back to the issue at hand, what does "Updating Library" mean? H'mmmm - this unit is a major disappointment. I wish my SL100 had never gone wonky. I'm missing my SL100 now and even though it was bigger, clunkier, and ran a lot hotter, I sure wish I had it back. :(
 

KOAJackies

New Member
Dec 7, 2008
3
0
1
Well, I've seen messages about updating channels many times before but this afternoon it gave me something like:

Updating Library - this may take several minutes to complete
And it did take 2 or 3 minutes and big surprise, after it was done all of my recordings (two Stern shows) were gone. That's the 3rd time in as many weeks that I've lost all recordings. My faith in it has gone down to zero - in fact if my timer does work and does record without erasing my other recordings it's like a pleasant surprise.

But back to the issue at hand, what does "Updating Library" mean? H'mmmm - this unit is a major disappointment. I wish my SL100 had never gone wonky. I'm missing my SL100 now and even though it was bigger, clunkier, and ran a lot hotter, I sure wish I had it back. :(
Same problem here. I spoke to SIRUIS, and they had me update the SW on the player. That worked for a few weeks, but the problem is back.

I record Howard everyday, and it's very frustrating to find 2 weeks worth of shows missing that were there the day before!!!!
 

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
16,985
4,987
168
Toronto, ON
Well, I've seen messages about updating channels many times before but this afternoon it gave me something like:

Updating Library - this may take several minutes to complete
And it did take 2 or 3 minutes and big surprise, after it was done all of my recordings (two Stern shows) were gone. That's the 3rd time in as many weeks that I've lost all recordings. My faith in it has gone down to zero - in fact if my timer does work and does record without erasing my other recordings it's like a pleasant surprise.

But back to the issue at hand, what does "Updating Library" mean? H'mmmm - this unit is a major disappointment. I wish my SL100 had never gone wonky. I'm missing my SL100 now and even though it was bigger, clunkier, and ran a lot hotter, I sure wish I had it back. :(

When I get it it is usually after strange things happen in the Library. The cause is that the SL has determined that the Library filesystem is corrupt. When it Updates it fixes the filesystem. Sometimes if a recording is corrupt it will wind up deleted. Othertimes, you will just have a silent radio for 3 minutes.

Some things I do to aleviate it: 1) regular (weekly) shutdowns. 2) Never shutdown when playing the Library. 3) Never do anything to it when it is recording or alter the recording in progress 4) Don't use sleep mode for recording (leave it on). 5) If you know of a channel update ... do not have a recording scheduled for that night.
 

North_of_Calgary

New Member
Oct 15, 2008
13
0
1
Well it did the "Updating Library" thing again on me. Clock symbol spun for a good 2 or 3 minutes before it completed. Interesting thing is that this time, beforehand I had nothing in my library. Zero recordings, zero replays, zero loved songs, zero MP3's, and no memory card. So I don't know what it was updating all that time.

In both cases, it was after a reboot. I know it's contrary to the general recommendation but I find that I my SL2 works best when I don't reboot it. Whenever I do (holding the power button down until it says "shutting down") I end up in trouble. Just letting it sleep makes it much more reliable for me.
 

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
16,985
4,987
168
Toronto, ON
Well it did the "Updating Library" thing again on me. Clock symbol spun for a good 2 or 3 minutes before it completed. Interesting thing is that this time, beforehand I had nothing in my library. Zero recordings, zero replays, zero loved songs, zero MP3's, and no memory card. So I don't know what it was updating all that time.

In both cases, it was after a reboot. I know it's contrary to the general recommendation but I find that I my SL2 works best when I don't reboot it. Whenever I do (holding the power button down until it says "shutting down") I end up in trouble. Just letting it sleep makes it much more reliable for me.

There are other things in memory .. you're presets, recording schedule, settings. The Updating Library means the memory is corrupt.

If you do not reboot at least weekly, I think your chance of corruption will go way up. When you finally do reboot .... you will get the Updating Library. In my cases, after this message, the unit is more stable. I think you will find that if you reboot regularly, aside from the initial 1 or 2 reboots, this message would not appear.