Sl2 power, charging issues

Discussion in 'Sirius Portables' started by jrg, Oct 14, 2010.

  1. jrg

    jrg New Member

    So, upon my return from an extended business trip my long-faithful SL2 will not charge its battery when docked (tried it with several different batteries and docks) and will not power up or play in the dock without a battery installed (apparently a well-adjusted SL2 will?). It will play in the dock and receive a satellite radio signal and record if the batterys is already charged. Luckily I had recently purchased a brand-spanking new SL2 from TSS as a backup, so right now I'm using that still unactivated device as a battery charger, and continuing to use my old SL2 to listen, record, play etc.

    Before I use one of my lifetime subscription device transfers (I purchased a discounted lifetime sub when Howard first went digital; I know, it owes me nothing, but still), has anyone seen this, and does anyone have a suggestion or quick fix?

    My TSS friends, might you be able to repair this?

    On top of that, my old SL2 is still under Best Buy warranty; anybody tried that one recently? Any and all suggestions welcome. Thanks.
  2. IdRatherBeSkiing

    IdRatherBeSkiing Sherbert is not and never will be ice cream

    I did a Future Shop exchange this March up here in Canada. They had SL2s in stock so they did a straight exchange.

    My guess is they would offer you an equivalent piece of equipment (perhaps an XMP3i). Not a bad deal as you can sit on it and use your backup SL2 for now.

    I would wait to the last possible moment to do the lifetime exchange personally.

    Have you tried a device recovery? It can make a hardware issue, or what seems like one, go away sometimes.
  3. I'm not sure if this is something that we would be able to fix, but I could give it a try. I'm curious, have you docked it into a powered docking station without a battery in it? If so, does it power on? This would tell me if something is out of whack with the connector on the bottom of the stiletto.
  4. Vols44

    Vols44 Well-Known Member

    Matt has a point. I had a charging issue because one contact point was obstructed. I'd also ensure the battery is fully seated and the female end on the Stiletto is free of dirt and dust prior to docking.
  5. jrg

    jrg New Member

    Hi and thanks for the Responses.

    Matt, I have tried docking in a powered dock: no response, with or without battery. Bottom line is it will play on any dock, but only so long as the battery is charged and I turn it on (unlike the usual where it automatically turns on when docked in a powered dock).

    Got a response from Droo to an e-mail sent directly to TSS; he suggests a device recovery, characterizing it as a long shot, but maybe its a device management software issue that will respond to a reset. I've waited a week, and nothing good has happened (and thanks Vols: I did check my seating and connections, nothing!), so guess I'll try a reset now. And Skiing: I agree the transfer is a very last choice: if it comes to that, I'll let you know how I fare at best buy.

    Thanks all.
  6. HecticArt

    HecticArt Administrator

    Good Luck!
  7. jrg

    jrg New Member

    SO FRUSTRATING. Did this at my desk while on a conference call. It appears that my recovered device IS taking a charge from my laptop when connected via my data cable (didn't think to check if it was charging that way prior to recovery), but still will not take a charge from the Soloist dock at my desk (my new, not-yet-activated Stiletto does).

    As soon as this endless call ends I am going to see if it will charge in my car via the power cable I have there. If not, I'll probably call Sirius and make the switch: a week of futzing around with batteries and docks is a week too much. Thanks.
  8. It does not charge the unit via USB cable. So if it isn't doing that, that's expected. But since it does not charge in the soloist, that makes me worry that there may be something wrong in the plug on the bottom of the radio.
  9. IdRatherBeSkiing

    IdRatherBeSkiing Sherbert is not and never will be ice cream

    It does charge via USB just slower.
  10. Hmm, I've never been able to get it to do that, or just never had the patience. I've had batteries die on me during device recoveries, which uses the usb cable to perform, so that's pretty much where I get that from. I have a full battery now, but I will let it drain for a bit and attach it via usb. I've never seen this work.
  11. IdRatherBeSkiing

    IdRatherBeSkiing Sherbert is not and never will be ice cream

    Perhaps it is one of those things that is supposed to work but doesn't always work depending on the particular unit. I could have sworn I saw my old SL2 charging while connected. Haven't had the misfortune *knock on wood* to hook my current one up to a PC yet.
  12. No, you are right. It does give a very slow trickle of power when connected to the USB. It's probably best to have a really strong battery plugged in when performing a device recovery. I let my battery run down a bit and plugged it in for a couple of hours. It isn't up to 100%, but it's getting there. It takes a while longer that the conventional method of charging, but it does work on my SL2.
  13. jrg

    jrg New Member

    FYI, I'm just judging by the little lightning bolt that appears next to the battery icon; I'm not sure its actually charging, but the bolt appeared when connected to my computer, but not in any dock.

    Anyway, I activated my new formerly standby SL2 (now I need a new standby; any expected at TSS?), and its off to Best Buy this weekend. Thanks all.
  14. JKoffler44

    JKoffler44 Member

    I've had this same problem for about a year now, I can't charge the unit in my home, or car dock. I can only charge it through my USB cable. I think one of those two connectors on the bottom went bad. Maybe the same issue for you?
  15. IdRatherBeSkiing

    IdRatherBeSkiing Sherbert is not and never will be ice cream

    Wondering if it will charge for you plugged directly into the AC adapter?
  16. Jerico

    Jerico New Member

    I've been having this issue on and off now for a number of years. I opened up the SL2 the first time it happened and looked around under a magnifying light I bought for my home woodshop. Fiddling with the wall wart in it (unplugged) I noticed a small trace on the right side of the dock (back off, screen down) near where the power goes in was broken. I soldered it with my non-fine tip soldering gun, and was off to the races! Based on the wall wart power diagram I determined it to be the positive power input. The whole dock connector was loose.

    Since then, I have had to open it up about twice a year to try and fix it and have purchased better soldering tips and gotten better at soldering in general. The soldering never stuck well with my original ham-fisted attempts, and since then I've been trying to repair around my mess of solder.

    Fast forward to today and I have now pooched the standard charging port and it will only charge via USB (better than nothing!). Does anyone know of a picture of the circuit board in that area, or where the positive charge GOES after it hits the circuit board? I assume the power is modulated in some way as I cannot find a trace of where it goes to. The negative is easy to find, but the positive must be modulated and thus harder to find with a standard continuity tester.

    I have successfully repaired stuff like iPods before, but there is considerably more of a wealth of info out there about them.

Share This Page