SL2 "Can't Play - File is Empty"

g0tr00t

New Member
May 20, 2009
4
0
1
I read the old thread and it looks like its too old to verify anything.

Does anyone have this problem still? Sirius is sending me my 3rd SL2 due to this erroring occuring about every 30 days....
 
Oct 10, 2008
644
11
18
Chicago
I haven't had that problem ever, but I will try and do a few things to replicate it. I think that going through stiletto after stiletto will not help you out. There is obviously a pattern of listening or use that you do that is causing this to happen. I would suggest doing a device recovery when this happens. It will eliminate dealing with Sirius and getting replacements. I really only feel that Sirius should be sending these for hardware related issues, and I'm certain this problem is software related.
 

g0tr00t

New Member
May 20, 2009
4
0
1
Hey Matt. Here is my setup. I set the recording to record 6 hours of Stern 7 days a week. I tell it to keep the last 5 shows and also have radio replay turned on. After about 30 days of doing this, my radio replays disappear, then my libarary erases and finally I get the "Can't play...." error.

If you google the error message, there was a LOOOOONG thread about it when the SL2 first came out. I am not sure if it's readable since it was on sirius backstage forums. I have also done all of the recovery, resets, upgrades available to me....I really hope the next one works.

In my opinion, its as if the stiletto has some software issue that consumes space or memory then kinda does a clean-up/crash fix. Once I reset/restore its fine for about 30 days, then it does it again.
 

Allanon

Member
Oct 17, 2008
313
16
18
Do you shutdown (e.g. press "off" for 10 seconds) your SL2 regularly? You need to do so to avoid memory corruption. Yes, it's an SL2 bug, but you can usually get around it with the regular shutdown.

In my opinion, its as if the stiletto has some software issue that consumes space or memory then kinda does a clean-up/crash fix. Once I reset/restore its fine for about 30 days, then it does it again.
 

g0tr00t

New Member
May 20, 2009
4
0
1
Do you shutdown (e.g. press "off" for 10 seconds) your SL2 regularly? You need to do so to avoid memory corruption. Yes, it's an SL2 bug, but you can usually get around it with the regular shutdown.


Nope....sheesh! Is that all it is? I do the regular shutdown, but hardly ever the hard reset.

Many thanks! I'll give it a try with the new one.
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,360
6,895
168
Toronto, ON
Hey Matt. Here is my setup. I set the recording to record 6 hours of Stern 7 days a week. I tell it to keep the last 5 shows and also have radio replay turned on. After about 30 days of doing this, my radio replays disappear, then my libarary erases and finally I get the "Can't play...." error.

If you google the error message, there was a LOOOOONG thread about it when the SL2 first came out. I am not sure if it's readable since it was on sirius backstage forums. I have also done all of the recovery, resets, upgrades available to me....I really hope the next one works.

In my opinion, its as if the stiletto has some software issue that consumes space or memory then kinda does a clean-up/crash fix. Once I reset/restore its fine for about 30 days, then it does it again.

All SL2s have the memory corruption. It happens after so much time regardless of what you do. Getting another from Sirius won't help as it will have the same issue. A Device Recovery when it happens will give you several more months. My guess is it is your radio replays particularly if you leave it on one channel for many hours. If you do the replays, do blocks no more then 2-3 hours. Just change the channel periodically and that should break it up.


Nope....sheesh! Is that all it is? I do the regular shutdown, but hardly ever the hard reset.

Many thanks! I'll give it a try with the new one.

This will increase the amount of time between corruption onset. It will not eliminate it (see above). I do it weekly -- every Saturday morning. Seems to make it work for a while.
 
Oct 10, 2008
644
11
18
Chicago
All excellent advice. Also, after you delete a recording it is best to shut down, not sleep, the stiletto and turn it back on. Much like adding or removing a program from a windows based computer, it will operate best after restarting it.
 

Ehilbert1

Ooh-Rah!!!!
Oct 13, 2008
4,480
1,219
113
Columbus, OH
I'm glad I read this thread. Thanks for all the advice on things guys. You really know your shit and I appreciate that. Hopefully my SL2 will last a while longer.
 

jemery.wa

New Member
Nov 23, 2008
1
0
1
the first time this started to happen to me (a couple of months ago) it would actually delete the show i was listening to WHILE i was listening to it in my library. i did a restore and it fixed the problem but this morning i went in to my library to listen to a recorded show from yesterday and low and behold my f****ing library is empty (should have a lot of recorded shows). looks like another restore is coming soon.

is there any hope on the horizon that they may put out a different portable, i like the XM portables but i have a lifetime sirius sub.