S100 stuck in recovery mode!

Discussion in 'Sirius Portables' started by psuJC, Nov 20, 2008.

  1. psuJC

    psuJC New Member

    Stupid me, I tried to update my Stiletto S100 last night, and ended up putting it in recovery mode. I connect it to the PC, run the Device Recover Program from Sirius, and it goes to download the firmware, and comes back with "Sorry, your PC must be connected to the internet" The thing is, it IS connected to the internet.

    I've tried this on 4 different PC's, and this morning on a different network. Same thing.

    I tried calling support, but after 3 different people I can't seem to find anyone who even knows what firmware is, let alone how to fix this problem. If I had to guess there's something going on with the firmware server, but I'm stuck. Any thoughts or ideas?
  2. nafddur

    nafddur Member

    I'd say just do a warranty exchange. You might have to upgrade to a Stiletto 2, of course (since I haven't seen SL100's in any stores in many months).
  3. psuJC

    psuJC New Member

    I've had it for more than 2 years, I'm sure it's out of warranty.
  4. psuJC

    psuJC New Member

    I found an old post on Sirius Backstage, and DAB confirmed it was a glitch on the server. Now the question is how to fix it again.
  5. nafddur

    nafddur Member

    Best Buy extended warranties (called PSP's) highly recommended by many of us ever since the early S50 days are 4 year warranties. So lots of us still have those in effect.
  6. psuJC

    psuJC New Member

    I finally got someone this morning who understood what I was talking about. They told me they escalated it to corporate and this afternoon i was able to restore it again.
  7. DAB

    DAB Mod Emeritus

    Hi psuJC, sorry that I missed your request for my assistance. I've sort of been in and out this week. I am glad to see that they got your issue resolved.

    This indeed as I recall was the solution that sometimes there was a glitch and they (Zing) at the time would pull your data log and review what was going on and they would then make some changes on their end that would allow certain tuners (now we call them radios) to do the recovery.
  8. psuJC

    psuJC New Member

    No Problem, I figured it couldn't hurt to ask, but I finally did get someone who knew enough to send the problem to the people who could fix it.

    During my investiation I found the device recovery program hits at least 3 different IP's. They're secure servers, but their certificates had problems. I couldn't see the security certificates, so I gave up, but If i had to guess, they changed server IP's, or let the certificates lapse. Either way, they fixed it, and it's all good now. I'm pretty sure this problem was also causing MSS updates to fail the way they have over the last couple days: It would tell you there's an update available, then fail on the download.
  9. Hungrybologna

    Hungrybologna New Member

    I had a similar problem with my SL2 this morning. I was trying to get the newest firmware and was unable to update so I did a device recovery. After trying several times it finally connected to the servers and grabbed the update. Not sure what I did different but it worked.
  10. XF_Honeycomb

    XF_Honeycomb New Member

    Like hungrybologna i did a device recovery, but on my sl100 about 2 weeks ago and mid way through it i got the must be connected to the internet message. I unhooked the cord from the sl100 and tried process over again and the 2nd time it work with out a flaw. So untill you get help from sirius, I would periodically try device recovery.

Share This Page