Reset Stiletto 100?

Oct 20, 2008
Golf Course
I have a Stiletto 100 that is pretty much a brick. Here is what happened.

Put battery in to go for a jog and about 2 minutes into it, it started skipping. I then got the Please plug into PC to recover.

I updated my MSS software and completed the recovery procedure and it worked for another day.

It kept doing this and now I can't even turn the unit on.

Are there any button combinations that I can push to get the thing to reset again?

Also, the PC does not see it anymore since it will not turn on.

I've since bought a Stiletto 2 and like it, but would like to be able to use this for something.


Oct 11, 2008
Herndon, VA

Here is the post from the SBS I did.

You can press the options and display keys... Follow these directions below:

In order to use the SIRIUS Recovery Device Program follow these steps:

(Please see the 5/18/07 Updated Note on the bottom of this post before starting this procedure!!!! )

1. First the unit must be COMPLETELY turned off. Not in sleep mode.

2. Before turning on, PRESS and HOLD the following Keys.

Now Turn on the Stiletto. You should see the following display.

3. Using the supplied USB cable that came with the Stiletto Connect your Stiletto to your PC.

The following screen should appear:

4. Select Recover Device

Once you select Recover, the following will be displayed on your Stiletto:

5. When the WARNING message appears on the screen, READ IT. You Will lose all your content!

Press - OK.

6. From here the unit will continue with the upgrade. It will download new firmware, Copy it to Device and install it. It takes about 15 minutes for the process.

Here are some of the displays you may see...

7. Finally, the Success screen is displayed.

You are prompted to close this screen. The stiletto will reboot as though it is powering on. Don't worry, the Dot Progression seems very slow the first time. But your Stiletto is as good as new!

The first time you plug in the radio, you get a warning about No Channels. I waited a minute, then the channels were available.


Once started I could not stop the process. Removing the battery and replacing it only brought it back to the Error! screen.

It seems that this update is NOT the latest firmware. Go back to MSS and check to make sure you have the latest firmware. You can also just listen via WiFi and it will automatically update as well.

I plan to update this page as I find out more options. This will probably be the start of another PDF doc.

Updated 1-15-07 by MM--> I just did this procedure and I used the home dock synched up to my computer, instead of the USB cable. It worked perfectly.

Updated 5-18-07 by DAB --> Make sure your MSS software can connect to your Stiletto before attempting to do the Recovery Procedure. If your MSS can not find your Stiletto then the recovery procedure will fail and you'll basically have a bricked device. If you have more than one computer you could try installing the MSS and checking to see if that computer will see your Stiletto. It is my opinion that often times these issues are computer related more than MSS or Stiletto related. AGAIN YOUR MSS and STILETTO MUST BE ABLE TO CONNECT TO EACH OTHER PRIOR TO ATTEMPTING THE RECOVERY PROCEDURE!
Oct 20, 2008
Golf Course
Well, I still couldn't get anything using that procedure. This morning, I pressed a couple of buttons just messing around and the Dog came on and didn't do anything else, so I know it's capable of being turned on, I just haven't been able to do so since.


New Member
Feb 9, 2009
Thanks Rubin, it worked for me! This is my 4th SL100, two purchased, two replacements under warranty. You save me a lot of time not having to deal with Sirus customer service.