Possible S50 firmware v0.0.0 fix

mattress67

New Member
Aug 24, 2009
1
0
1
I've have an S50 that recently died. When turned on, it would show the last station acquired, with two bars of reception -- all channels were frozen. Yes, I updated the software back in the Spring of 09, and the radio continued to work fine up until last month. The radio was purchased in 2006. Some additional info.

Some other descriptions of my problem. When put into dock, S50 only shows "Sirius" logo. This of course can be bypassed by selecting settings. All MP3/recorded content is accessible. Only satellite functions are inop. Also, under device settings, Sirius ID does not work (only in dock). Satellite shows zero reception (still two bars on channel display). If channels are selected, either a message "No Channels Available" is displayed. Or, last successful channel accessed with two bars of reception, or after a 3-finger reset, channel 184 with two bars of reception (even without antenna attached). After various resets and software updates, when put back in dock the unit would freeze on "firmware Update." Or if I attempted to reset channels, the unit would freeze on "Please wait."

Finally, using the Siruis studio updater on PC, current firmware would display v0.0.0. No matter what, I could not get it to update to the current firmware of v0.5.56. Also, forget Sirius support, they can't help you with this one and will say the radio is dead and encourage you to buy a new one or accept one of their most basic radios.

So, the solution? Well for me I did this. And I'm posting it here cause I'd like to see if I just got lucky, or did I do something right.

Okay, so I really never suspected the S50 itself. I felt that the docking station could have been the culprit (and I have two). However, I also wondered if my battery could be causing a problem as it is over three years old and can't hold a charge. Interesting to me, the S50 will power up without the battery inserted when connected to a PC. When put into the dock without the battery, it will initially power up but then shut down. So, I started to wonder if the firmware update required a fully charged battery to update the docking stations properly? In the past, I didn't think it mattered as I assumed the docking station would provide power.

Regardless, I put the battery back in, and put the S50 back into the docking station and for no particular reason selected "reset channels," which normally causes a freeze. I left the until and about thirty minutes later returned to find the S50 working.

So, is the solution to "firmware v0.0.0," (or any of the other symptoms I mentioned) to just insert the S50 into the docking station WITHOUT the battery, power up. Take out insert battery, re-dock, channel reset? Is an old battery really the culprit in being unable to update the docking station?

I knew my S50 wasn't a brick! And I wonder how many people have tossed their S50's without trying what I did. I'll be curious to hear if anyone finds this posting useful.
 

jeffbat

New Member
Sep 25, 2009
1
0
1
Same Problem

You pretty much explained my exact problem. Of course I called Sirius and they said my radio was dead and out of warranty. I am trying what you did right now while holding for a 2nd level tech support. Amazing that everything you said is exactly what mine was doin. Ill let you know what happens with mine. Is yours still working properly?
 

dyusufi

New Member
Dec 5, 2009
1
0
1
I have the exact problem...tried the battery thing...no luck. Any progress on your ends?