new SL2 wont connect to wifi?

redmenter

New Member
Oct 2, 2009
13
0
1
Hello,
i tried reading and searching past posts for an answer, but couldnt find anything to work for me. I just bought the SL2, activated it, and it works fine. well other than crappy reception, but thats for another topic ! I even hooked into my pc, and it updated whatever software/firmware so its up to date with that.
Well i am trying to connect to my wifi, and no luck. i had wep security, it saw my network, i entered password, and it wouldn't connect. tried 10 or so times. So i rebooted router and radio, still nada. So i turned off all security on my router wireless settings, and tried it. radio see it, now shows its unlocked network, i hit connect, it says checking, blabla... then says can not connect ???? now all my laptops, pc's work fine with my router, (linksys wrt54gs). I have rebooted router 2 or 3 times with no seccurity setting in tact, still will not connect. WHAT can it try? I have shut down SL2 and started it up a dozen times, and no connect. but why??
My next steps are go to a starbucks and see if it connects to see if its my network?? and then call sirius support (which i am sure is a joke, thats why i am here!)
Ohh and besides activating via telephone i have not done anything to my account online, i do not pay for the $2.95/mo internet radio package, but i dont think you have to to use the wifi feature on the SL2 ? right? I only have one radio on my account.
any help appreciated
thanks !!!
 

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
21,612
9,270
168
Toronto, ON
You might want to delete your network from the SL2 networks list and refind it. Hope this helps.

Monty

Good advice.

If you have a failure, you definatly need to delete the network and try again. Try with an unsecured network first, add the security later. Make sure your router does not restrict by MAC address. I have mine set to and when a friend brings their laptop over sometimes we forget that until they can't connect. So if you restrict, make sure you add your SL2s MAC address. Frequent full reboots of the SL2 and the router will help make sure neither are in a funny state.

Good luck. It took me a couple of hours to do mine. Now it works flawlessly. Most of the changes were done on my router.
 

redmenter

New Member
Oct 2, 2009
13
0
1
Hey,
Thanks for suggestions. My network in the SL2 list?? i have never connected so i am not sure it is "in" my radios list? it pops up when it searches for networks, but again, not sure its in my list?
I have rebooted both many times at this point. My router as i stated was set for WEP security, but i have turned off all security on my router, so anyone and everyone can connect right now. I have friends over who can connect with no issue, my 2 laptops connect no issue.
sooooo,, hmmmmmmmmmm,, lost again????

thanks guys !!!
 

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
21,612
9,270
168
Toronto, ON
Hey,
Thanks for suggestions. My network in the SL2 list?? i have never connected so i am not sure it is "in" my radios list? it pops up when it searches for networks, but again, not sure its in my list?
I have rebooted both many times at this point. My router as i stated was set for WEP security, but i have turned off all security on my router, so anyone and everyone can connect right now. I have friends over who can connect with no issue, my 2 laptops connect no issue.
sooooo,, hmmmmmmmmmm,, lost again????

thanks guys !!!

It is. Every attempt is stored. This is particularly an issue if you had security and then turned it off.

One other thing, make sure your router is running the latest firmware. I had to upgrade my router's firmware for the SL2 to connect. It appears that my router (as well as a lot of others appearantly) had a bug with their WPA and WEP security routines. The firmware update corrected this. I suspect that your friends computers are likely less picky about the protocol as the SL2. The SL2 is pretty anal about its handshaking and if it is not to its liking 100% it will not connect.

But clear your network and try without security. Once you have established connection, try adding the security. FYI: I have mine set on WPA and it works. My router is a TRENDNet router.

Good luck.
 

redmenter

New Member
Oct 2, 2009
13
0
1
Hey
In the background while the it is doing its checking network screen while trying to connect i see in the status line, in the background it does go to "connected" , but the radio is still showing checking network at that point, then i get the unable to connect, and then that status line goes to "network check failed" ????
I updated my router firmware to latest, rebooted, rebooted SL2, still wont connect? you mention to clear the network list?? i still am unsure where i am to do this???? I go to settings, wifi, then it shows to categories, wifi on and device list, mine shows wifi as "on" and for network list it shows a "0" and if i click into that it just says how it will store networks i have successfully connected to in here. But i dont have any as of now?

soooooooooooooo,, any more idea'rs ??? haha....
once again thank you