new SL2 owner.

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Okay, so I may be late to the game, but I just got a SL2 of my own finally. (Thanks tss-radio! Taylor specifically. Good deal!) Prior to this I had a SL10 but it was pretty crummy, the abttery was shot and I only used it to record stern in the morning, then listened to it that day. Since it couldn't hold more than one show at a time. Now, I can record all week and catch up later.

This SL2 is amazing in comparison. I don't know how I lived without the WiFi and SIR. And having more Logos that show up on this thing than on my SL10! Haha. Also, I loaded up a 8 gig MicroSD card with Music (most of it was Zune purchases marketplace stuff) and it works just fine. Awesome! Already impressed with this little guy. Fits much nicer into my hand and pocket than the older SL10, too.

The only issue I am having at the moment is when I turn the radio off and on, and go from my library or SIR to Satellite, it goes to "updating sirius" and never gets past that, I need to reset it to make it go. It's hit or miss, but it still is not a major issue for me so far.

Sorry if this is redundant to you guys here, but I just wanted to express my love for my new toy.
 

HecticArt

Administrator
Oct 19, 2008
40,707
12,118
168
Toledo, Ohio
Glad you got a duce!

I haven't had those issues. But I don't really record and I don't use the WiFi very often.
Do you have the latest firmware installed? That may help the wifi stability.

Also, there is a thread that has some handy maintenance tips and tricks that can help you improve your performance.
 
  • Like
Reactions: Grüpsaar

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Yeah, I'm reading up on the maintenance stuff right now. I was listening via Wifi and it updated the ZAP and stuff, so that's all up t date, I got all the correct logos now. Thanks!
 

Vargas

Molon Labe!
Oct 16, 2008
3,426
153
63
Western, PA
Welcome to the SL2 club.

I've had it since it came out and I still love it--by far my most used device.

I HIGHLY recommend doing a HARD SHUT down at least once per week, more if you are going to be recording a lot.

Also, I recommend turning it off when planning on switching from WIFI to SAT. I listen to wifi in my office for hours in the boombox and then will rip it out to go in my car. When I wouldn't do a soft turn off, sometimes it would freeze or get very sluggish.

Also, the Invisible Sheild is a good idea if you're going to be doing a lot of transporting. My goes from car to office to upstairs to here and there. Until recently it was also my primary MP3 player so it saw a lot of gym use.

The WIFI alone makes the SL2 worth it.

ENJOY!!!
 
  • Like
Reactions: Grüpsaar

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Thanks for the advice! I was thinking of an invisible shield, but I don't think I'll care too much if it gets bit of character and scuff marks. I am usually pretty good to my stuff. my SL10 saw A LOT of use and still fucntions fine. It got dropped on pavement and banged around in bags and came out pretty good in the end.

As for the sitching from Wifi and Sat...I am still having my issue. I canr ecreate it each time. I go from WIFI to Sat, and when I try to goto Sat, it says "channel not available, please subscribe by calling blah blah blah" and then when I switch to it, it says "Updating Sirius" forever and has yet to change. I do a hard shut down and it boots up, and displays "Subscription updated" everytime, then functions fine.
 

Vargas

Molon Labe!
Oct 16, 2008
3,426
153
63
Western, PA
Thanks for the advice! I was thinking of an invisible shield, but I don't think I'll care too much if it gets bit of character and scuff marks. I am usually pretty good to my stuff. my SL10 saw A LOT of use and still fucntions fine. It got dropped on pavement and banged around in bags and came out pretty good in the end.

As for the sitching from Wifi and Sat...I am still having my issue. I canr ecreate it each time. I go from WIFI to Sat, and when I try to goto Sat, it says "channel not available, please subscribe by calling blah blah blah" and then when I switch to it, it says "Updating Sirius" forever and has yet to change. I do a hard shut down and it boots up, and displays "Subscription updated" everytime, then functions fine.

I had that problem for one day. I did a hard shut down, took out the battery for about 10 minutes and restarted it and it was ok.

I would try this and see what happens. If this doesn't fix it, call SIRIUS asap!
 

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
I had that problem for one day. I did a hard shut down, took out the battery for about 10 minutes and restarted it and it was ok.

I would try this and see what happens. If this doesn't fix it, call SIRIUS asap!
Funny, I was just doing that now! Thanks though, I'll try keeping the battery out fora while and see. It's just agonizing waiting in silence for 10 minutes! Haha.
 

Vargas

Molon Labe!
Oct 16, 2008
3,426
153
63
Western, PA
Funny, I was just doing that now! Thanks though, I'll try keeping the battery out fora while and see. It's just agonizing waiting in silence for 10 minutes! Haha.

When mine did it, it got stuck in the "updating" mode and that little circle just kept moving. I have no idea why or how this happened. If I remember correclty, it was either just after they merged all the channels so I thought it might have been some sort of problem with that.

Best of luck, keep us updated on it and let us know.
 

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
20,137
7,833
168
Toronto, ON
Congrats.

Its a nice radio. One thing I would do in addition to other things mentioned is to do a device recovery to get updates. I have always had wierd issues with mine if I patched it via WiFi or MSS. A device recovery gives you a clean(er) copy of the OS at the latest patch level.
 

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Congrats.

Its a nice radio. One thing I would do in addition to other things mentioned is to do a device recovery to get updates. I have always had wierd issues with mine if I patched it via WiFi or MSS. A device recovery gives you a clean(er) copy of the OS at the latest patch level.

Thanks! I my try this tonite since i can't get my updating sirius problems resolved so far it seems. Might as well do it now before I get too many settings and such personalized.
 

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Just did the recovery, and my issue seems fixed. Thanks!

One strange thing after the recovery I noticed, I went to WiFi, and it immediately listed "all channels", however they were out of order, 40's on 4 being the first, then some random country station, then I saw "punk" and it's logo. I had hit the home button, but caught it at the last second. I scrolled back to "all channels" and everything was listed neatly and in order. And punk was gone. Or is it still available online somewhere? Maybe it just didn't have a fresh list yet since it was newly recovered and then quickly fixed itself.

Edit: spoke too soon. Problem is back. "Updating Sirius" displays when going back to SAT after Wifi. I am going to let it sit at that screen tonite and see if something happens. If this is a real issue, I am going to be slightly bummed. But I'll still love my SL2
 
Last edited:

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
20,137
7,833
168
Toronto, ON
Just did the recovery, and my issue seems fixed. Thanks!

One strange thing after the recovery I noticed, I went to WiFi, and it immediately listed "all channels", however they were out of order, 40's on 4 being the first, then some random country station, then I saw "punk" and it's logo. I had hit the home button, but caught it at the last second. I scrolled back to "all channels" and everything was listed neatly and in order. And punk was gone. Or is it still available online somewhere? Maybe it just didn't have a fresh list yet since it was newly recovered and then quickly fixed itself.

Edit: spoke too soon. Problem is back. "Updating Sirius" displays when going back to SAT after Wifi. I am going to let it sit at that screen tonite and see if something happens. If this is a real issue, I am going to be slightly bummed. But I'll still love my SL2

It sounds to me like you may have a hardware issue. Since you have just bought it, I would recommend talking to TSS about an exchange. I believe they do this within the first N days (60? 90?) but I could be wrong -- call them though. They are good guys.

You could call Sirius but you will get some bumped an broken refurbished unit. Either way, since it is a warrentee exchange, Sirius should waive the $15 transfer fee.
 

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Hm, it's just too bad that this newer Radio is having issues doing simple things that my SL10 still do fine to this day. My scheduled recording for Stern did not go this morning, and when I tried tuning to 100, it wouldn't do anything. I select it fom the list, and it just sits there. Hitting in "100" on the remote has no response. Same with any channel. Going to internet radio didn't do much either. connected, then went back to the main menu. Had to do a hard shutdown to fix that.

The Updating Sirius thing went away after I left it on most of the night, though. It did a channel update, and seems okay for now.
 

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
20,137
7,833
168
Toronto, ON
Hm, it's just too bad that this newer Radio is having issues doing simple things that my SL10 still do fine to this day. My scheduled recording for Stern did not go this morning, and when I tried tuning to 100, it wouldn't do anything. I select it fom the list, and it just sits there. Hitting in "100" on the remote has no response. Same with any channel. Going to internet radio didn't do much either. connected, then went back to the main menu. Had to do a hard shutdown to fix that.

The Updating Sirius thing went away after I left it on most of the night, though. It did a channel update, and seems okay for now.

This is an occassional bug with the SL2. If you can't engage the satrad you need to do a hard shutdown and startup. If you get in this mode, recordings won't happen or if they do will usually be corrupted.
 

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
I just saw this. Grup if you want the unit swapped out just let us know asap. I mean our shipping cut off is in an hour or so.

Thanks, but today the main issues seem resolved. No more freezing or locking up when going from wifi to sat, and the recording seems okay 'for now'. I think it just needed a proper reboot and stuff after the whole reset. Thigns seem to be ironing out and running smoother. The test will be tomorrows recording, but vent hen, I will be okay, just a matter of ironing out the issues and stuff. It's just a new set of nuances to learn. When I got my SL10 I had a few things I had to adjust to and learn about.

So, in short, This thing is awesome!
 

IdRatherBeSkiing

Sherbet is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
20,137
7,833
168
Toronto, ON
Thanks, but today the main issues seem resolved. No more freezing or locking up when going from wifi to sat, and the recording seems okay 'for now'. I think it just needed a proper reboot and stuff after the whole reset. Thigns seem to be ironing out and running smoother. The test will be tomorrows recording, but vent hen, I will be okay, just a matter of ironing out the issues and stuff. It's just a new set of nuances to learn. When I got my SL10 I had a few things I had to adjust to and learn about.

So, in short, This thing is awesome!

Keep in mind that when the WiFi is active, the sat chips are off. I do not believe it will record a program if it is in WiFi mode. It will also not record if completely shutdown. I also tend to not trust sleep mode too much for recording either.
 

Grüpsaar

DRC Forum Bum
Oct 11, 2008
2,361
100
63
33
Anytown, WI
www.youtube.com
Yeah, I was aware of the wifi/shutdown thing, I check to make sure the sats were off when in wifi mode, and I figured that out prior to going to sleep last night, also, I only did a slepe mode last night when going to bed, so it shouldn't have been completly shut down. I never had any issues with my SL10 recording when in sleep mode, so I figured the SL2 would handle the same way, but perhaps something was wrong with all the weirdness it had last night, so maybe after all of its use today it has the kinks worked out and is ready to record. I am not to keen on leaving it on all night so it can record. I used to do that with my SL10 before I could trust it to wake up from sleep mode to record, and I just felt uneasy about it for some reason. We shall see tomorrow. So far today though it's been working pretty well.