Its been almost 2 months ...

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,298
6,824
168
Toronto, ON
Its been almost 2 months since I took the latest firmware fix for my SL2 via Device Recovery.

I have had power fail in the middle of a recording.
I have had the buffer activated while it recorded.

I have yet to lose one recording or loved song. The unit has been unusually stable. I have done no more reboots than before. I have treated it the same as before. Did they fix the memory corruption with the last fix? Has anyone had recording issues since the update?

If so, have you had issues after a device recovery with the latest firmware?

I am wondering if I am just waiting for the inevitable or whether the problem may actually be fixed.

Thoughts? Experiences?
 

Allanon

Member
Oct 17, 2008
313
16
18
If so, have you had issues after a device recovery with the latest firmware?

I am wondering if I am just waiting for the inevitable or whether the problem may actually be fixed.

Thoughts? Experiences?

I've inadvertently done one of the proscribed actions (delete a recording while another one was being recorded) two weeks ago, and I automatically got memory corruption. To fix the problem, I had to do a "reset" (not a full recovery) and lose all my recordings... I've had no other problem since the last update.

On a related subject: I noticed that the love button now works consistently on channel 79, and quite often on channel 80! That's a big improvement (for me).

I can't say that they fixed the corruption. Probably that you are simply more careful and are not doing corruption triggering operations.
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,298
6,824
168
Toronto, ON
I've inadvertently done one of the proscribed actions (delete a recording while another one was being recorded) two weeks ago, and I automatically got memory corruption. To fix the problem, I had to do a "reset" (not a full recovery) and lose all my recordings... I've had no other problem since the last update.

On a related subject: I noticed that the love button now works consistently on channel 79, and quite often on channel 80! That's a big improvement (for me).

I can't say that they fixed the corruption. Probably that you are simply more careful and are not doing corruption triggering operations.


I have always been careful. I don't look at the thing while it is recording. It has not spared me in the past. So far, so good.
 

Vargas

Molon Labe!
Oct 16, 2008
3,426
151
63
Western, PA
Its been almost 2 months since I took the latest firmware fix for my SL2 via Device Recovery.

I have had power fail in the middle of a recording.
I have had the buffer activated while it recorded.

I have yet to lose one recording or loved song. The unit has been unusually stable. I have done no more reboots than before. I have treated it the same as before. Did they fix the memory corruption with the last fix? Has anyone had recording issues since the update?

If so, have you had issues after a device recovery with the latest firmware?

I am wondering if I am just waiting for the inevitable or whether the problem may actually be fixed.

Thoughts? Experiences?


I've been problem free. ALthough, don't get too much out of that because I really don't record very often.
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,298
6,824
168
Toronto, ON
I seem to have the opposite problem now. I can't delete recordings. If I try to delete a recording, the whole unit will just freeze. I do a hard reboot and it does an "Updating Library" and the recording re-appears in the list. Occassionally it will let me delete one. When I delete the 2nd one, it hangs and both recordings re-appear after the library gets updated. If the SL2 does its own deletions, it is fine.

I will probably do another device recovery at my earliest convenience (when I have listened to all the recorded content I want).
 

siriusnj

Member
Oct 29, 2008
45
1
8
Its been almost 2 months since I took the latest firmware fix for my SL2 via Device Recovery.

I have had power fail in the middle of a recording.
I have had the buffer activated while it recorded.

I have yet to lose one recording or loved song. The unit has been unusually stable. I have done no more reboots than before. I have treated it the same as before. Did they fix the memory corruption with the last fix? Has anyone had recording issues since the update?

If so, have you had issues after a device recovery with the latest firmware?

I am wondering if I am just waiting for the inevitable or whether the problem may actually be fixed.

Thoughts? Experiences?

I wouldn't get too excited - I recently went through a stretch where I had no issues, and just "felt" that it was bound to happen soon, so I wrote down all of my loved songs. Go figure, 2 days later, my entire library was wiped out. :( This was last week. Problems still not fixed.
 

PWbandit

New Member
Mar 23, 2009
17
0
1
So CAL ~ 310
Im having issues, but my favorited song, radio recording, and radio replays are all there, but my device will not "Acquire Signal" unless it is docked.

I guess i was farting around at work and paused the radio - heard it un-pause after an hour...forwarded thru that hour of recordings to a song i wanted to hear. Found one, and I wanted to check if i had it recorded, so i went to the library, seen it there, and decided not to record. When i got back to the radio (by pressing home twice) the dam thing went haywire and lost signal! Being on the 45th floor, i tried going outside and removing the battery. No bueno!

Now my device will not "Acquire Signal", unless docked. I guess i can anticpate a further corruption and another necessary reboot? Maybe just a collection of anomolies at the wrong time, or had anyone else experienced this?
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,298
6,824
168
Toronto, ON
Im having issues, but my favorited song, radio recording, and radio replays are all there, but my device will not "Acquire Signal" unless it is docked.

I guess i was farting around at work and paused the radio - heard it un-pause after an hour...forwarded thru that hour of recordings to a song i wanted to hear. Found one, and I wanted to check if i had it recorded, so i went to the library, seen it there, and decided not to record. When i got back to the radio (by pressing home twice) the dam thing went haywire and lost signal! Being on the 45th floor, i tried going outside and removing the battery. No bueno!

Now my device will not "Acquire Signal", unless docked. I guess i can anticpate a further corruption and another necessary reboot? Maybe just a collection of anomolies at the wrong time, or had anyone else experienced this?

I think I misunderstood your issue before. I thought you were getting Aquiring Signal when docked. I have never got a satisfactory signal from the SL2 in standalone mode. I always need the antenna headphones or docking. The internal antenna kind of sucks unless you are right next to a repeater.
 

PWbandit

New Member
Mar 23, 2009
17
0
1
So CAL ~ 310
I think I misunderstood your issue before. I thought you were getting Aquiring Signal when docked. I have never got a satisfactory signal from the SL2 in standalone mode. I always need the antenna headphones or docking. The internal antenna kind of sucks unless you are right next to a repeater.


I rarely dock, and always gets signal, using only my Bose earbuds. I guess im in Los angeles, so there are probably plenty of repeaters and such. The more i look around, the more i think i am experiencing a corruption issue.

Thanks again for all your help.
:bigthumbup:
 

IdRatherBeSkiing

Sherbert is NOT and NEVER WILL BE ice cream.
Oct 11, 2008
19,298
6,824
168
Toronto, ON
I rarely dock, and always gets signal, using only my Bose earbuds. I guess im in Los angeles, so there are probably plenty of repeaters and such. The more i look around, the more i think i am experiencing a corruption issue.

Thanks again for all your help.
:bigthumbup:

A device recovery may be an option you should consider then. It will do a complete rebuid of memory including the OS.