How long does it take?

Serious

New Member
Dec 28, 2008
3
0
1
I updated my account to include the best of xm on my SL2 yesterday but this morning it is still not added.What is up with that?They can bill the credit card immediately but not give the service?
I am tuned to 184 and no Xm.
 

hexagram

Medicinal & Recreational.
Oct 11, 2008
2,760
96
48
Seattle, WA
Why didn't you stay on the phone with the CS rep while they were sending the signal down to your radio?

Call them up, and have them re-send it.
 

Serious

New Member
Dec 28, 2008
3
0
1
I added it on the internet yesterday,no csr,and figured they would resent activation but they did not and this morning I decided I would have to resend activation online,15 minutes after resending nothing happened but checked it again an hour later and everything is in.
 

syphix

Member
Oct 15, 2008
366
10
18
On my SL100, when I upgraded, I had to turn the radio off after a while, then back on. Then the channels appeared.
 

gldwng84

New Member
Jan 1, 2009
2
0
1
Turn off radio

I had to turn radio off not to sleep but power it off and pull battery and then reinstall it then mine worked perfectly. good luck.
 

joe2k4

Member
Nov 12, 2008
187
4
18
Same here they resent it 3 times and finally I just did a shutdown and then when I turned it on it was there.
 

Vols44

Well-Known Member
Oct 18, 2008
1,225
136
63
To fix my last mess up I resent a signal from my account page and it took all of five minutes to reset things so I hope all went well Serious.