Anybody Successfully Done Device Recovery On Windows 7?

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
17,200
5,077
168
Toronto, ON
My SL2 started messing up recordings again. And I was ready to do a 'Reset+Erase' except the "Device" menu is kind of not there anymore. No doubt the OS is corrupted. I remember last time this was discussed, the general feeling was Device Recovery did not work on Windows 7. Is this still the case or has anybody successfully done one on Windows 7? And more importantly, does SXM still support it? I am unwilling to try if it will brick my radio as it still works and may be good for something.

Thoughts? Suggestions?
 

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
17,200
5,077
168
Toronto, ON
I did find the software on the siriusxm.com website. No mention of O/S. I will try installing it and see what happens.
 

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
17,200
5,077
168
Toronto, ON
Didn't work. Got some weird error. Bummer. Well, it was fun while it lasted. The brick is still my ticket to cheap internet radio.
 

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
17,200
5,077
168
Toronto, ON
Dig through the threads here to see if you can find it. It wasn't too long ago.
Did he get it to work on win7 or did he find an XP machine? I don't think I have an old Xp machine that works.

I also tried in compatibility mode and that also failed.


Sent from my iPhone5 using Tapatalk
 

Vols44

Well-Known Member
Oct 18, 2008
1,197
108
63
I use VMWare to run XP under 7. That might be worth a shot.
Got it loaded on my laptop (with Windows 7 Professional) it takes a while to load. I'd give it a shot before you choose to send it to TSS. They have a PC with XP and MSS just for this purpose.
 
  • Like
Reactions: HecticArt

IdRatherBeSkiing

Sherbert is not and never will be ice cream
Oct 11, 2008
17,200
5,077
168
Toronto, ON
My SL2 has stopped recording again. It changes the channel and turns on the little heart and keeps it on well past the end of the recording. Nothing is showing up in the library. I tried to do a reset + erase again and this time it goes all the way to the 'yes, do it' prompt before doing nothing. Looks like another device recovery. Also looks like a failing piece of hardware. :(